Intermittent latency and failure detected while submitting the transactions to Mastercard payment gateway service

Incident Report for noon payments

Resolved

The reported issue has been resolved in which customers may have experienced an intermittent failure while submitting the transactions to Mastercard payment gateway services between 21:02 UTC - 21:59 UTC, 29 March 2025.

Thank you for your patience and continued support.
Posted Mar 30, 2025 - 00:07 UTC

Investigating

We are observing intermittent latency and failure while submitting the transactions to Mastercard payment gateway service.

We will post further updates till the resolution of the issue.

Thank you for your patience and continued support.
Posted Mar 29, 2025 - 21:39 UTC
This incident affected: Production Environment - Saudi Arabia (Acquirers/Gateways Performance).