Intermittent latency and failure while submitting the transactions to Mastercard Payment Gateway for Asia/Pacific region

Incident Report for noon payments

Resolved

The reported issue has been resolved in which customers may have experienced an intermittent latency and failures while submitting the transactions to Mastercard Payment Gateway Service in the Asia/Pacific region between 01:42 - 03:46 UTC, 24 February 2026.

Mastercard team has confirmed that the service has been restored and working as expected.

Thank you for your patience and continued support.
Posted Feb 24, 2026 - 06:29 UTC

Identified

A service degradation has been identified for Mastercard Payment Gateway Service in Asia/Pacific region starting at 01:42 UTC, 24 February 2026.

Mastercard team is currently working towards mitigation of the issue.

We will post further updates once we receive the same from the Mastercard team.

Thank you for your patience and continued support.
Posted Feb 24, 2026 - 03:28 UTC
This incident affected: Acquirers/Gateways.