Intermittent failure detected while submitting the transactions to Mastercard Payment Gateway Service

Incident Report for noon payments

Resolved

The reported issue has been resolved in which customers may have experienced intermittent failure detected while submitting the transactions to Mastercard payment gateway services between 17:13 Hrs. - 17:31 Hrs. UTC, 10 July 25.

The service has been restored and working as expected.

Thank you for your patience and continued support.
Posted Jul 10, 2025 - 18:13 UTC

Monitoring

We are no longer seeing intermittent failure detected while submitting the transactions to Mastercard Payment Gateway Service

We are continuing to monitor the issue and will advise once we receive confirmation from Mastercard team.

Thank you for your patience and continued support.
Posted Jul 10, 2025 - 17:54 UTC

Update

A service degradation has been identified for Mastercard Gateway in the Kingdom of Saudi Arabia.

Mastercard team is investigating the issue on priority.

We will post further updates once we receive the same from the Mastercard team

Thank you for your patience and continued support.
Posted Jul 10, 2025 - 17:45 UTC

Investigating

We are observing intermittent failure in transactions starting at 17:13 UTC, 10 July 2025

We are currently investigating the issue.

We will post further updates till resolution of issue.

Thank you for your patience and continued support.
Posted Jul 10, 2025 - 17:20 UTC
This incident affected: Acquirers/Gateways and Archived (Acquirers/Gateways Performance).