The reported issue has been resolved in which customers may have experienced an intermittent transaction failure on Noon Payment infrastructure in Saudi Arabia region between 04:12 - 08:25 Hrs. UTC, 01 Sep 2026.
Services have been restored and working as expected.
Thank you for your patience and continued support.
Posted Sep 01, 2026 - 09:39 UTC
Monitoring
Transaction processing has resumed and is currently functioning for Production Environment-Saudi Arabia
Our teams are actively monitoring the systems to ensure continued stability.
We will provide further updates as necessary.
Thank you for your patience and continued support
Posted Sep 01, 2026 - 08:47 UTC
Investigating
We are again observing intermittent transaction failure.
We are currently investigating the issue.
We will post further updates till resolution of issue.
Thank you for your patience and continued support.
Posted Sep 01, 2026 - 04:58 UTC
Monitoring
We are no longer observing internittent transaction failure.
We will post further updates till resolution of issue.
Thank you for your patience and continued support.
Posted Sep 01, 2026 - 04:23 UTC
Investigating
We are observing intermittent transaction failure.
We are currently investigating the issue.
We will post further updates till resolution of issue.
Thank you for your patience and continued support.
Posted Sep 01, 2026 - 04:07 UTC
This incident affected: Noon Payments - Production (Saudi Arabia - Production).