Intermittent transactions failure detected from STC bank Issuer

Incident Report for noon payments

Resolved

The reported issue has been resolved in which customers may have experienced an intermittent decline from STC Bank issuer while submitting the transactions between 08:33 - 11:12 Hrs. UTC, 11 July 2025

The service has been restored and working as expected.

Thank you for your patience and continued support.
Posted Jul 11, 2025 - 11:52 UTC

Monitoring

We are no longer seeing the intermittent declines from STC Bank card issuer while submitting the transactions.

We are continuing to monitor the issue and will post further updates till the resolution of the same.

Thank you for your patience and continued support.
Posted Jul 11, 2025 - 11:17 UTC

Investigating

We are observing an intermittent decline from STC Bank issuer while submitting the transactions.

We will post further updates till the resolution of the issue.

Thank you for your patience and continues support.
Posted Jul 11, 2025 - 08:47 UTC
This incident affected: Issuers and Archived (Issuers).