Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 10, 2025 - 03:30 UTC
Scheduled
The Mastercard team has a planned activity in which they are performing scheduled maintenance for the Mastercard Gateway and Regional Service Center in Kingdom of Saudi Arabia region (KSA) between 03:30 - 10:30 Hrs. UTC, 10 July 2025.
During the scheduled maintenance window, customers may experience an intermittent increase in transaction timeouts and/or failed transactions.
Posted Jul 03, 2025 - 10:03 UTC
This scheduled maintenance affected: Acquirers/Gateways and Archived (Acquirers/Gateways Performance).