Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 24, 2025 - 21:00 UTC
Scheduled
MADA will perform a scheduled maintenance for below entities as per mentioned time intervals:
Entity Name Start Time End Time First Abu Dhabi Bank 21:00 UTC, 24 April 2025 05:00 UTC, 25 April 2025 Aljazeera Bank 01:00 UTC, 25 April 2025 03:00 UTC, 25 April 2025
During the scheduled maintenance window, customers may experience an intermittent failure in the ecommerce transactions.
Posted Apr 23, 2025 - 10:14 UTC
This scheduled maintenance affected: Production Environment - Global (Issuers) and Production Environment - Saudi Arabia (Issuers).