The scheduled maintenance activity has been successfully completed.
Thank you for your cooperation and patience during this period.
Posted Jul 07, 2025 - 04:22 UTC
Update
Please be informed that the current activity is being extended by 1 hour.
We appreciate your patience and will notify you once the activity is completed.
Thank you for your understanding and support.
Posted Jul 07, 2025 - 03:58 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 07, 2025 - 02:00 UTC
Scheduled
Noon Payments team will be performing a scheduled maintenance on the Payment Gateway Services for Global and Saudi Arabia environments between 02:00 - 04:00 Hrs. UTC, 7 July 2025.
During the scheduled maintenance window, customers may experience drift in response and timeout while processing the requests.
Posted Jul 04, 2025 - 05:57 UTC
This scheduled maintenance affected: Noon Payments - Production (Global - Production, Saudi Arabia - Production).