Intermittent latency and timeout while submitting the transactions to Mastercard payment gateway services- Saudi Arabia

Incident Report for noon payments

Resolved

The reported issue has been resolved in which customers may have experienced an intermittent latency and errors while submitting the transactions to Mastercard payment gateway service for Saudi Arabia region between 01:43 - 02:04 UTC, 20 January 2026.

Mastercard team confirmed that service has been restored and working as expected.

Thank you for your patience and continued support.
Posted Jan 20, 2026 - 03:14 UTC

Investigating

A service disruption has been identified for Mastercard Payment Gateway Services for Saudi Arabia region.

Mastercard team is working to resolve the issue on priority.

Customers may experience intermittent latency and error while submitting transaction to Mastercard payment gateway service.

We will post further updates from Mastercard till resolution of issue.

Thank you for your patience and continued support.
Posted Jan 20, 2026 - 02:27 UTC
This incident affected: Acquirers/Gateways.