Intermittent transactions failure detected from STC pay (Non banking issuer)
Incident Report for noon payments
Resolved
The reported issue has been resolved in which customers may have experienced intermittent declines from STC Pay (non-banking issuer) while submitting the transactions between 08:11 Hrs. UTC - 09:22 Hrs. UTC, 07 November 2024.

The service has been restored and working as expected.

Thank you for your patience and continued support.
Posted Nov 07, 2024 - 10:05 UTC
Monitoring
We are no longer seeing the intermittent declines from STC pay (non banking issuer) while submitting the transactions.

We are continuing to monitor and will post further updates till the restoration of the issue.

Thank you for your patience and continued support.
Posted Nov 07, 2024 - 09:33 UTC
Investigating
We are observing intermittent declines from STC Pay (non-banking issuer) while submitting the transactions.

We will post further updates till the resolution of the issue.

Thank you for your patience and continued support.
Posted Nov 07, 2024 - 08:27 UTC
This incident affected: Production Environment - Global Endpoints (Issuers) and Production Environment - KSA Endpoints (Issuers).